
<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>

		<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://www.checkpointasia.net/xmlrpc.php" />
<title>US Troops Are Fighting Houthis in Yemen</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Checkpoint Asia &raquo; Feed" href="https://www.checkpointasia.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Checkpoint Asia &raquo; Comments Feed" href="https://www.checkpointasia.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Checkpoint Asia &raquo; US Troops Are Fighting Houthis in Yemen Comments Feed" href="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/feed/" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","share_counts_url":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"},"url_components":{"year":"2018","monthnum":"05","day":"06","post_id":"5379","postname":"us-troops-are-fighting-houthis-in-yemen","author":"markocpa"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false'
        src='//apps.shareaholic.com/assets/pub/shareaholic.js'
        data-shr-siteid='e8b7bbd611887a019d1ca7266e3d02d0' async='async' >
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Checkpoint Asia' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/' />
<meta name='shareaholic:keywords' content='politics, war, post' />
<meta name='shareaholic:article_published_time' content='2018-05-06T05:39:55+00:00' />
<meta name='shareaholic:article_modified_time' content='2018-05-06T05:53:12+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Marko Marjanović' />
<meta name='shareaholic:site_id' content='e8b7bbd611887a019d1ca7266e3d02d0' />
<meta name='shareaholic:wp_version' content='8.6.5' />
<meta name='shareaholic:image' content='https://i0.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets-1.jpg?fit=700%2C467&amp;ssl=1' />
<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.checkpointasia.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='https://checkpointasia.b-cdn.net/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='travelify-parent-style-css'  href='https://checkpointasia.b-cdn.net/wp-content/themes/travelify/style.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='travelify_style-css'  href='https://checkpointasia.b-cdn.net/wp-content/themes/travelify-child/style.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_ubuntu-css'  href='//fonts.googleapis.com/css?family=Ubuntu&#038;ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/css/jetpack.css?ver=6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bnd = {"is_single":"1","post_id":"5379","ajax_url":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/themes/travelify-child/js/custom.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/themes/travelify/library/js/functions.min.js?ver=4.9.5'></script>
<link rel='https://api.w.org/' href='https://www.checkpointasia.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.checkpointasia.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://checkpointasia.b-cdn.net/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.5" />
<link rel="canonical" href="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/" />
<link rel='shortlink' href='https://wp.me/p7FF1z-1oL' />
<link rel="alternate" type="application/json+oembed" href="https://www.checkpointasia.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.checkpointasia.net%2Fus-troops-are-fighting-houthis-in-yemen%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.checkpointasia.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.checkpointasia.net%2Fus-troops-are-fighting-houthis-in-yemen%2F&#038;format=xml" />
			<meta property="fb:pages" content="341139456234749" />
			<meta property="fb:pages" content="341139456234749" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>    <style type="text/css">
        a { color: #008000; }
        #site-title a { color: #000142; }
        #site-title a:hover { color: #000142; }
        .wrapper { background: #F8F8F8; }
        .social-icons ul li a { color: #000142; }
        #main-nav a, #main-nav a:hover,  #main-nav a:focus, #main-nav ul li.current-menu-item a,#main-nav ul li.current_page_ancestor a,#main-nav ul li.current-menu-ancestor a,#main-nav ul li.current_page_item a,#main-nav ul li:hover > a { color: #fff; }
        .widget, article { background: #fff; }
        .entry-title, .entry-title a, .entry-title a:focus, h1, h2, h3, h4, h5, h6, .widget-title  { color: #0a0a0a; }
        a:focus, a:active, a:hover, .tags a:hover, .custom-gallery-title a, .widget-title a, #content ul a:hover,#content ol a:hover, .widget ul li a:hover, .entry-title a:hover, .entry-meta a:hover, #site-generator .copyright a:hover { color: #008000; }
        #main-nav { background: #000142; border-color: #000142; }
        #main-nav ul li ul, body { border-color: #000142; }
        #main-nav a:hover,#main-nav ul li.current-menu-item a,#main-nav ul li.current_page_ancestor a,#main-nav ul li.current-menu-ancestor a,#main-nav ul li.current_page_item a,#main-nav ul li:hover > a, #main-nav li:hover > a,#main-nav ul ul :hover > a,#main-nav a:focus { background: #000142; }
        #main-nav ul li ul li a:hover,#main-nav ul li ul li:hover > a,#main-nav ul li.current-menu-item ul li a:hover { color: #000142; }
        .entry-content { color: #0a0a0a; }
        input[type="reset"], input[type="button"], input[type="submit"], .entry-meta-bar .readmore, #controllers a:hover, #controllers a.active, .pagination span, .pagination a:hover span, .wp-pagenavi .current, .wp-pagenavi a:hover { background: #000142; border-color: #000142 !important; }
        ::selection { background: #000142; }
        blockquote { border-color: #000142; }
        #controllers a:hover, #controllers a.active { color: #000142; }
        input[type="reset"]:hover,input[type="button"]:hover,input[type="submit"]:hover,input[type="reset"]:active,input[type="button"]:active,input[type="submit"]:active, .entry-meta-bar .readmore:hover, .entry-meta-bar .readmore:active, ul.default-wp-page li a:hover, ul.default-wp-page li a:active { background: #000142; border-color: #000142; }
    </style>
    <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="icon" href="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2016/11/favifavi.jpg?fit=24%2C24&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2016/11/favifavi.jpg?fit=24%2C24&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2016/11/favifavi.jpg?fit=24%2C24&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2016/11/favifavi.jpg?fit=24%2C24&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


.post-sub-title a {
	color : #0c0c0c !important;
	    text-decoration: none;
}
#jp-relatedposts .jp-relatedposts-items-visual .jp-relatedposts-post img.jp-relatedposts-post-img {
	  width: 100%;
    left: 0 !important;
    height: auto !important;
    top: 0 !important;
}			</style>
		<style id="yellow-pencil">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</style>
<!-- START - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.4.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:url" content="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/"/>
  <meta property="og:description" content="The US military is more deeply involved in the Saudi War in Yemen than officials ever admitted. In fact, new evidence suggests the Pentagon lied to Congress during the March debate about US involvement, presenting the US role at present being limited to targeting and mid-air refueling of Saudi warpl"/>
  <meta property="og:image" content="https://checkpointasia.b-cdn.net/wp-content/uploads/2018/05/green-berets-1.jpg"/>
  <meta property="article:published_time" content="2018-05-06T05:39:55+00:00"/>
  <meta property="article:modified_time" content="2018-05-06T05:53:12+00:00" />
  <meta property="og:updated_time" content="2018-05-06T05:53:12+00:00" />
  <meta property="article:section" content="Politics"/>
  <meta property="article:section" content="War"/>
  <meta property="article:publisher" content="https://www.facebook.com/CheckpointAsia/"/>
  <meta property="fb:admins" content="https://web.facebook.com/marko.marjanovic.169405"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="US Troops Are Fighting Houthis in Yemen"/>
  <meta itemprop="headline" content="US Troops Are Fighting Houthis in Yemen"/>
  <meta itemprop="description" content="The US military is more deeply involved in the Saudi War in Yemen than officials ever admitted. In fact, new evidence suggests the Pentagon lied to Congress during the March debate about US involvement, presenting the US role at present being limited to targeting and mid-air refueling of Saudi warpl"/>
  <meta itemprop="image" content="https://checkpointasia.b-cdn.net/wp-content/uploads/2018/05/green-berets-1.jpg"/>
  <meta itemprop="datePublished" content="2018-05-06"/>
  <meta itemprop="dateModified" content="2018-05-06T05:53:12+00:00" />
  <meta itemprop="author" content="Jason Ditz"/>
  <!--<meta itemprop="publisher" content="Checkpoint Asia"https://checkpointasia.b-cdn.net/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="US Troops Are Fighting Houthis in Yemen"/>
  <meta name="twitter:url" content="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/"/>
  <meta name="twitter:description" content="The US military is more deeply involved in the Saudi War in Yemen than officials ever admitted. In fact, new evidence suggests the Pentagon lied to Congress during the March debate about US involvement, presenting the US role at present being limited to targeting and mid-air refueling of Saudi warpl"/>
  <meta name="twitter:image" content="https://checkpointasia.b-cdn.net/wp-content/uploads/2018/05/green-berets-1.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@AsiaCheckpoint"/>
 <!-- SEO -->
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.4.1 -->
	

</head>

<body class="post-template-default single single-post postid-5379 single-format-standard custom-background ">
	
	<div class="wrapper">
				<header id="branding" >
				
	<div class="container clearfix">
		<div class="hgroup-wrap clearfix">
					<section class="hgroup-right">
											</section><!-- .hgroup-right -->
				<hgroup id="site-logo" class="clearfix">
					
				</hgroup><!-- #site-logo -->

		</div><!-- .hgroup-wrap -->
	</div><!-- .container -->
		<nav id="main-nav" class="clearfix">
					<div class="container clearfix"><ul class="root"><li id="menu-item-634" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-634"><a href="http://www.checkpointasia.net/">Home</a></li>
<li id="menu-item-646" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-646"><a href="https://www.checkpointasia.net/category/politics/">Politics</a></li>
<li id="menu-item-647" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-647"><a href="https://www.checkpointasia.net/category/war/">War</a></li>
<li id="menu-item-1190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1190"><a href="https://www.checkpointasia.net/category/financ/">Finance</a></li>
<li id="menu-item-648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-648"><a href="https://www.checkpointasia.net/category/society/">Society</a></li>
<li id="menu-item-710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-710"><a href="https://www.checkpointasia.net/category/history/">History</a></li>
<li id="menu-item-635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-635"><a href="https://www.checkpointasia.net/about/">About</a></li>
<li id="menu-item-636" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-636"><a href="https://www.checkpointasia.net/team/">Team</a></li>
<li id="menu-item-637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-637"><a href="https://www.checkpointasia.net/contact/">Contact</a></li>
<li id="menu-item-641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-641"><a href="https://www.checkpointasia.net/submissions/">Submissions</a></li>
<li id="menu-item-644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-644"><a href="https://www.checkpointasia.net/support/">Support</a></li>
<li id="menu-item-711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-711"><a href="https://www.checkpointasia.net/category/books/">Books</a></li>
</ul></div><!-- .container -->
					</nav><!-- #main-nav -->				</header>
		
				<div id="main" class="container clearfix">

<div id="container">
	

<div id="primary" class="no-margin-left">
   <div id="content">	<section id="post-5379" class="post-5379 post type-post status-publish format-standard has-post-thumbnail hentry category-politics category-war">
		<article>

			
			<header class="entry-header">
    			<h2 class="entry-title">
    				US Troops Are Fighting Houthis in Yemen    			</h2><!-- .entry-title -->								<div class="entry-title">				<h3 class="post-sub-title"><a href="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/">Saudis can't handle the war they started, Uncle Sam bailing them out</h3></a>				</div>
  		</header>

  		
  		
  			<div class="entry-meta-bar clearfix">
    			<div class="entry-meta">
	    				<span class="byline"> <span class="author vcard"><a class="url fn n" href="https://www.checkpointasia.net/author/markocpa/">Jason Ditz</a></span></span><span class="posted-on"><a href="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/" rel="bookmark"><time class="entry-date published" datetime="2018-05-06T05:39:55+00:00">6 May 18</time><time class="updated" datetime="2018-05-06T05:53:12+00:00">6 May 18</time></a></span>	    					             		<span class="category"><a href="https://www.checkpointasia.net/category/politics/" rel="category tag">Politics</a>, <a href="https://www.checkpointasia.net/category/war/" rel="category tag">War</a></span>												<span class="view-info">3</span>
	             		    					             		<span class="comments"><a href="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="5379 https://www.checkpointasia.net/?p=5379">0</span></a></span>
	             	    			</div><!-- .entry-meta -->
    		</div>

				
				
  			<div class="entry-content clearfix">
    			<div class='shareaholic-canvas' data-app='share_buttons' data-title='US Troops Are Fighting Houthis in Yemen' data-link='https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/' data-app-id='25533197' data-app-id-name='post_above_content'></div><div id="attachment_5380" style="width: 1010px" class="wp-caption alignnone"><img data-attachment-id="5380" data-permalink="https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/green-berets/" data-orig-file="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?fit=1000%2C500&amp;ssl=1" data-orig-size="1000,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="green-berets" data-image-description="" data-medium-file="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?fit=600%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?fit=700%2C350&amp;ssl=1" class="wp-image-5380 size-full" src="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?resize=700%2C350&#038;ssl=1" alt="" width="700" height="350" srcset="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?w=1000&amp;ssl=1 1000w, https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?resize=600%2C300&amp;ssl=1 600w, https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?resize=768%2C384&amp;ssl=1 768w, https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?resize=750%2C375&amp;ssl=1 750w, https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/green-berets.jpg?resize=300%2C150&amp;ssl=1 300w" sizes="(max-width: 700px) 100vw, 700px" data-recalc-dims="1" /><p class="wp-caption-text"><em>Green Berets are sneaking into Yemen to target Houthi missiles &#8212; which are lobbed at Riyadh as retaliation for the starvation blockade Saudi Arabia has imposed on the country with US help</em></p></div>
<p>The US military is more deeply involved in the Saudi War in Yemen than officials ever admitted. In fact, new evidence suggests the <a href="https://www.nytimes.com/2018/05/03/us/politics/green-berets-saudi-yemen-border-houthi.html">Pentagon lied to Congress</a> during the <a href="https://news.antiwar.com/2018/03/18/trump-administration-scrambles-to-convince-congress-not-to-halt-yemen-war/">March debate about US involvement,</a> presenting the US role at present being limited to targeting and mid-air refueling of Saudi warplanes.</p>
<p>The<a href="https://www.nytimes.com/2018/05/03/us/politics/green-berets-saudi-yemen-border-houthi.html"> New York Times is reporting </a>on Thursday that <strong>there are actually a small number of US special forces on the ground at the Saudi border with Yemen. Those troops have not only been on the ground since late 2017, but are there on a mission to help the Saudi military fight Yemen’s Shi’ite Houthi movement.</strong></p>
<p>No public debate took place with respect to this deployment. Indeed, the Pentagon appears to have gone to great lengths not to tell the American public or the Congress about the Green Berets they sent to the border. <strong>The Green Berets are intended to help the Saudis “locate and destroy” Houthi missile caches, and attack Houthi launch sites inside Yemen.</strong></p>
<p>This has been going on despite the Trump Administration telling Congress that America’s involvement in Yemen was purely “non-combat,” and again, despite the Pentagon repeatedly saying that America’s sole involvement in Yemen was logistics and support for the air war.</p>
<p>Sen. Tim Kaine (D-VA) said the Pentagon was deliberately “blurring the lines between train and equip missions and combat.” <strong>It is unclear from the New York Times report if the US troops crossed into Yemen, but given that their mission was to target Houthi sites, it seems almost certain that they have.</strong></p>
<p>Centcom Commander Gen. Joseph Votel, during the March debate, did say that he had authorization to “help the Saudis defend their border.” At that time, however, he told the Senate this was being done purely through intelligence sharing and “military advice.” Clearly, it also involved physical US troops on the border.</p>
<p>It remains to be seen what the consequences of the Pentagon’s deception will be domestically. At the very least it seems like this could provide a new pretext for a vote on ending US involvement in the Yemen War, as Congress lacked all the information they needed to have an informed vote in March.</p>
<p>Source: <a href="https://news.antiwar.com/2018/05/03/us-army-special-forces-secretly-sent-to-saudi-border-with-yemen/"><strong>Antiwar.com</strong></a></p>
<p>PS.: If the Saudi <a href="https://www.checkpointasia.net/patriot-missiles-are-made-in-america-and-fail-everywhere/">Patriot batteries</a> were successfully intercepting Houthi missiles <a href="https://www.checkpointasia.net/us-saudi-war-in-yemen-once-again-us-powerless-to-supress-enemy-missiles/">as the Saudis and the Americans claim</a> there would be little need to risk US troops in covert raids deep into Houthi-held Yemen. The fact the Saudo-Americans are resorting to this is another indication <a href="https://www.checkpointasia.net/they-lied-again-american-missile-defense-failed-to-stop-yemeni-scud-headed-for-riyadh/">the Patriots are not successful</a>.</p>
<div class='shareaholic-canvas' data-app='share_buttons' data-title='US Troops Are Fighting Houthis in Yemen' data-link='https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/' data-app-id='25533193' data-app-id-name='post_below_content'></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>  			</div>

  						<ul class="default-wp-page clearfix">
				<li class="previous"><a href="https://www.checkpointasia.net/americas-new-13-billion-aircraft-carrier-cannot-operate-aircraft/" rel="prev"><span class="meta-nav">&larr;</span> America&#8217;s New $13 Billion Aircraft Carrier Cannot Operate Aircraft</a></li>
				<li class="next"></li>
			</ul>
			
	<!-- Here we load disqus comments -->
	<div class="dcl-disqus-thread" id="comments" >
	<div id="disqus_thread">
		</div>
	</div>
	
		
			<script type="text/javascript">
	/* <![CDATA[ */
		var disqus_url = 'https://www.checkpointasia.net/us-troops-are-fighting-houthis-in-yemen/';
		var disqus_identifier = '5379 https://www.checkpointasia.net/?p=5379';
		var disqus_container_id = 'disqus_thread';
		var disqus_domain = 'disqus.com';
		var disqus_shortname = 'checkpoint-asia';
		var disqus_title = "US Troops Are Fighting Houthis in Yemen";
		var disqus_config = function () {
			var config = this; // Access to the config object
			config.language = '';

			/* Add the ability to add javascript callbacks */
			
			/*
			   All currently supported events:
				* preData — fires just before we request for initial data
				* preInit - fires after we get initial data but before we load any dependencies
				* onInit  - fires when all dependencies are resolved but before dtpl template is rendered
				* afterRender - fires when template is rendered but before we show it
				* onReady - everything is done
			 */

			config.callbacks.preData.push(function() {
				// clear out the container (its filled for SEO/legacy purposes)
				document.getElementById(disqus_container_id).innerHTML = '';
			});
						config.callbacks.onReady.push(function() {
				// sync comments in the background so we don't block the page
				var script = document.createElement('script');
				script.async = true;
				script.src = '?cf_action=sync_comments&post_id=5379';

				var firstScript = document.getElementsByTagName( "script" )[0];
				firstScript.parentNode.insertBefore(script, firstScript);
			});
								};
	/* ]]> */
	</script>
	
		
	<script type="text/javascript">
	/* <![CDATA[ */
		var DsqLocal = {
			'trackbacks': [
				],
			'trackback_url': "https:\/\/www.checkpointasia.net\/us-troops-are-fighting-houthis-in-yemen\/trackback\/"		};
	/* ]]> */
	</script>
			
		</article>
	</section>
</div><!-- #content --></div><!-- #primary -->


<div id="secondary">
	

<aside id="top-posts-2" class="widget widget_top-posts"><h3 class="widget-title">Most Read</h3><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="https://www.checkpointasia.net/the-israeli-idf-isnt-nearly-the-invincible-army-its-cracked-up-to-be/" title="The Israeli IDF Isn&#039;t Nearly the Invincible Army It&#039;s Cracked up to Be" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i1.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/1111111.jpg?fit=542%2C325&#038;ssl=1&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="The Israeli IDF Isn&#039;t Nearly the Invincible Army It&#039;s Cracked up to Be" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://www.checkpointasia.net/the-israeli-idf-isnt-nearly-the-invincible-army-its-cracked-up-to-be/" class="bump-view" data-bump-view="tp">
								The Israeli IDF Isn&#039;t Nearly the Invincible Army It&#039;s Cracked up to Be							</a>
						</div>
											</li>
									<li>
												<a href="https://www.checkpointasia.net/ordered-to-help-facilitate-north-korea-negotiations-bolton-is-instead-sabotaging-them/" title="Ordered to Help Facilitate North Korea Negotiations Bolton Is Instead Sabotaging Them" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i1.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/77.jpg?fit=758%2C395&#038;ssl=1&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="Ordered to Help Facilitate North Korea Negotiations Bolton Is Instead Sabotaging Them" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://www.checkpointasia.net/ordered-to-help-facilitate-north-korea-negotiations-bolton-is-instead-sabotaging-them/" class="bump-view" data-bump-view="tp">
								Ordered to Help Facilitate North Korea Negotiations Bolton Is Instead Sabotaging Them							</a>
						</div>
											</li>
									<li>
												<a href="https://www.checkpointasia.net/the-empire-wont-be-brought-down-by-either-china-or-russia-it-will-be-done-in-by-its-debt/" title="The Empire Won&#039;t Be Brought Down by China or Russia. It Will Be Done in by Its Debt" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i2.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/746564.jpg?fit=1085%2C723&#038;ssl=1&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="The Empire Won&#039;t Be Brought Down by China or Russia. It Will Be Done in by Its Debt" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://www.checkpointasia.net/the-empire-wont-be-brought-down-by-either-china-or-russia-it-will-be-done-in-by-its-debt/" class="bump-view" data-bump-view="tp">
								The Empire Won&#039;t Be Brought Down by China or Russia. It Will Be Done in by Its Debt							</a>
						</div>
											</li>
									<li>
												<a href="https://www.checkpointasia.net/russian-jamming-has-grounded-us-drones-over-syria/" title="Russian Jamming Has Grounded US Drones Over Syria" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i0.wp.com/www.checkpointasia.net/wp-content/uploads/2018/04/dd.jpg?fit=600%2C400&#038;ssl=1&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="Russian Jamming Has Grounded US Drones Over Syria" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://www.checkpointasia.net/russian-jamming-has-grounded-us-drones-over-syria/" class="bump-view" data-bump-view="tp">
								Russian Jamming Has Grounded US Drones Over Syria							</a>
						</div>
											</li>
									<li>
												<a href="https://www.checkpointasia.net/americas-worst-enemy-is-its-trillion-dollar-military/" title="America&#039;s Worst Enemy Is Its Trillion-Dollar Military" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i0.wp.com/www.checkpointasia.net/wp-content/uploads/2018/05/11.jpg?fit=750%2C500&#038;ssl=1&#038;resize=40%2C40" class='widgets-list-layout-blavatar' alt="America&#039;s Worst Enemy Is Its Trillion-Dollar Military" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://www.checkpointasia.net/americas-worst-enemy-is-its-trillion-dollar-military/" class="bump-view" data-bump-view="tp">
								America&#039;s Worst Enemy Is Its Trillion-Dollar Military							</a>
						</div>
											</li>
				</ul>
</aside><div ><form target='_blank' action='https://www.paypal.com/cgi-bin/webscr' method='post'><input type='hidden' name='cmd' value='_donations' /><input type='hidden' name='business' value='editor@checkpointasia.net' /><input type='hidden' name='item_name' value='' /><input type='hidden' name='item_number' value='' /><input type='hidden' name='currency_code' value='USD' /><input type='hidden' name='amount' id='amount_1f5a122fe6a892a600de6b399dd34d1c' value='' /><input type='hidden' name='no_note' value='1'><input type='hidden' name='no_shipping' value='1'><input type='hidden' name='notify_url' value='https://www.checkpointasia.net/wp-admin/admin-post.php?action=add_wpedon_button_ipn'><input type='hidden' name='lc' value='EN_US'><input type='hidden' name='bn' value='WPPlugin_SP'><input type='hidden' name='return' value='' /><input type='hidden' name='cancel_return' value='' /><input class='wpedon_paypalbuttonimage' type='image' src='https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif' border='0' name='submit' alt='Make your payments with PayPal. It is free, secure, effective.' style='border: none;'><img alt='' border='0' style='border:none;display:none;' src='https://www.paypal.com/EN_US/i/scr/pixel.gif' width='1' height='1'></form></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!--LiveInternet counter--><script type="text/javascript"><!--
document.write("<a href='//www.liveinternet.ru/click' "+
"target=_blank><img src='//counter.yadro.ru/hit?t44.6;r"+
escape(document.referrer)+((typeof(screen)=="undefined")?"":
";s"+screen.width+"*"+screen.height+"*"+(screen.colorDepth?
screen.colorDepth:screen.pixelDepth))+";u"+escape(document.URL)+
";"+Math.random()+
"' alt='' title='LiveInternet' "+
"border='0' width='2' height='2'><\/a>")
//--></script><!--/LiveInternet-->
</div></aside>
</div><!-- #secondary --></div><!-- #container -->


	   </div><!-- #main -->

	   
	   
	   <footer id="footerarea" class="clearfix">
			


<div id="site-generator">
				<div class="container"><div class="copyright">Copyright &copy; 2018</div><!-- .copyright --><div class="footer-right"></div><div style="clear:both;"></div>
			</div><!-- .container -->
			</div><!-- #site-generator --><div class="back-to-top"><a href="#branding"></a></div>		</footer>

		
	</div><!-- .wrapper -->

	
	<div style="display:none">
	</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201818'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tve_dash_front = {"ajaxurl":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php","force_ajax_send":"","is_crawler":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/thrive-leads/thrive-dashboard/js/dist/frontend.min.js?ver=2.0.33'></script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php","nonce":"37219ad4e0","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.checkpointasia.net\/wp-login.php?redirect_to=https%3A%2F%2Fwww.checkpointasia.net%2Fus-troops-are-fighting-houthis-in-yemen%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://checkpointasia.b-cdn.net/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script type="text/javascript">/*<![CDATA[*/if ( !window.TL_Const ) {var TL_Const={"security":"076d8b01cf","ajax_url":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php","forms":[],"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":1,"main_group_id":5365,"display_options":{"allowed_post_types":[],"flag_url_match":false},"custom_post_data":[],"current_screen":{"screen_type":4,"screen_id":5379},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]};} else {ThriveGlobal.$j.extend(true, TL_Const, {"security":"076d8b01cf","ajax_url":"https:\/\/www.checkpointasia.net\/wp-admin\/admin-ajax.php","forms":[],"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":1,"main_group_id":5365,"display_options":{"allowed_post_types":[],"flag_url_match":false},"custom_post_data":[],"current_screen":{"screen_type":4,"screen_id":5379},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]})} /*]]> */</script><script  type="text/javascript">

    var disqus_shortname = "checkpoint-asia";
    if (typeof ds_loaded == "undefined") {
        var ds_loaded = false;
    }
    function loadDisqus() {
        var disqus_div = document.getElementById("disqus_thread");
        var top = disqus_div.offsetTop;
        var disqus_data = disqus_div.dataset;
        if ( !ds_loaded && ( window.scrollY || window.pageYOffset ) + window.innerHeight > top ) {
            ds_loaded = true;
            for (var key in disqus_data) {
                if (key.substr(0,6) == "disqus") {
                    window["disqus_" + key.replace("disqus","").toLowerCase()] = disqus_data[key];
								}
                }
                var dsq = document.createElement("script");
                dsq.type = "text/javascript";
                dsq.async = true;
                dsq.src = "https://" + window.disqus_shortname + ".disqus.com/embed.js";
                if(document.getElementById("dcl-hidden-div")) {
                    document.getElementById("dcl-hidden-div").innerHTML = "Loading...";
                }
                (document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
            }
        }
					var disqus_div_new = document.getElementById("disqus_thread");
		var divExists = disqus_div_new != null;
                if(document.body.scrollHeight < window.innerHeight){
                    loadDisqus();
                } else if(divExists) {
                    window.onscroll = function() { loadDisqus(); }
                }
	</script><script   type='text/javascript'>
                /* <![CDATA[ */
                var hash = window.location.hash;
                var disqus_shortname = 'checkpoint-asia';
                if(hash!==''){
                    var ds_loaded = true;
                    var dcl_loaded = 1;
                    (function() {
                        var dsq = document.createElement('script'); dsq.type = 'text/javascript';
                        dsq.async = true;
                        dsq.src = '//' + disqus_shortname + '.' + 'disqus.com' + '/' + 'embed' + '.js' + '?pname=wordpress&pver=2.84';
                        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
                    })();}
                /* ]]> */
            </script><script type='text/javascript' src='https://stats.wp.com/e-201818.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1',blog:'113363501',post:'5379',tz:'0',srv:'www.checkpointasia.net'} ]);
	_stq.push([ 'clickTrackerInit', '113363501', '5379' ]);
</script>

</body>
</html>
<!-- Page generated by LiteSpeed Cache 2.2.3 on 2018-05-06 05:59:16 -->